• 717-761-4113

  • 3925 Trindle Road Camp Hill, PA. 17011

  • Hours: Mon. - Fri. 8:30 AM to 5:00 PM

Testimonials

"I am very pleased with the service I received from your company. I mailed the cluster on Thursday and received it on Monday. It is back in the vehicle and tested. All worked fine. Thank you." Alan W.

Alan W.

"Will tell everyone I know about your cluster program. We are an auto salvage and sales co. We get lots of clients. Thanks again."

Ray - 6/11/2015

"My cluster works great after you made the proper repairs to it. Your turn around time was outstanding. Thank You."

William - 2/22/2016

"Just wanted to send a note of appreciation for the fast service on repairing my Ford instrument cluster. It is refreshing to find a business with fine service such as yours. Thank you!"

Charlie - 9/8/2015

"The repaired cluster works like a champ!! You guys are awesome. I’m back to my 130K odometer, and the fuel gauge is on the money thanks to you and the tech for such excellent service. If you know of someone that would like to buy a 312K cluster that’s in perfect shape other than high miles just send them my way. It’s going into a box to be stored for now."

Steve

"If anyone needs cluster repair I will for sure tell them to take it to you. Thanks again."

Rob - 10/22/2014

"Keith – thanks for the great service."

Larry M.

"Thanks for fixing my instrument cluster it works great and the repair was fast. 2008 Ford Econoline."

Paul S.

"I have a motorhome on a 2002 F-53 chassis. The instrument cluster is # 1C3F10849HA. The voltage gauge just wiggled when the key was turned on. It would slowly build to around 8 with the the engine running for a while. I had the alternator checked-it was ok. I installed a digital voltage gauge which shows 14.1-14.2 with the engine running. After sending it in for repair, I received the instrument cluster this morning, installed it and everything works fine now. Thanks!"

Curtis - 8/21/2015

"I wanted to get back with you and thank you for your input on my problem. We replaced the speed sensor on the rear end with an aftermarket part and the transmission still wouldn’t shift and the Speedo didn’t work. We then replaced the speed sensor with the Ford part and everything worked fine after that. Thanks again and I hope your business does well."

Tom


Hello There