• 717-761-4113

  • 3925 Trindle Road Camp Hill, PA. 17011

  • Hours: Mon. - Fri. 8:30 AM to 5:00 PM

Testimonials

"Thank you greatly for fixing the light on my Escape cluster. I understand it was simply replacing a light bulb, but you saved me lots of money. The Ford dealer said I needed to replace the cluster, which would have been expensive. I thought there had to be a better way to make this work again and you did that. Now, I don’t have to be concerned my teenage drivers might accidentally put the car in the wrong gear when driving at night. Thanks again."

Cliff - 10/18/2014

"Hey Guys, I just wanted to thank you for your great work and quick turn around on my 2003 Trailblazer cluster. It all worked great after installation!! I will highly recommend your company to anyone who needs a similar repair. Again, thanks for a great job!!!!!!!!"

Tom S.

"Just a short note to say thanks for sending me the Speedo / Tach Pegs for my 95 Ford Mustang GT. Please forgive me for taking too much time in thanking you. I have handed out your company literature to a couple of sources that do repair on autos. I have also made extra copies to hand out in the future. Thank you again for assisting me in this project."

Bruce - 6/11/2015

"I had a really great experience with this company. The pricing structure is very easy to understand. They include shipping (both ways) in the estimate and their service was not just on time, but faster than they promised. The cluster we had repaired, worked perfectly and our customer was extremely happy. I would recommend them to anyone and I will be using them again in the future."

Louie - 7/6/2015

"I received the cluster yesterday morning, and by the evening, I had it re-installed in the car. It works great. Thank you very much! I will be sure to post on both forums the great service you have provided to encourage other owners to contact you to get their clusters fixed. Thanks again."

Philip - 6/24/2015

"I have a motorhome on a 2002 F-53 chassis. The instrument cluster is # 1C3F10849HA. The voltage gauge just wiggled when the key was turned on. It would slowly build to around 8 with the the engine running for a while. I had the alternator checked-it was ok. I installed a digital voltage gauge which shows 14.1-14.2 with the engine running. After sending it in for repair, I received the instrument cluster this morning, installed it and everything works fine now. Thanks!"

Curtis - 8/21/2015

"I wanted to get back with you and thank you for your input on my problem. We replaced the speed sensor on the rear end with an aftermarket part and the transmission still wouldn’t shift and the Speedo didn’t work. We then replaced the speed sensor with the Ford part and everything worked fine after that. Thanks again and I hope your business does well."

Tom

"The unit I sent back last year that you guys rebuilt, for my 91 Crown Vic, is working flawlessly. I have recommended you guys to several motor heads and friends in my area. Stay well."

George L

"Keith – thanks for the great service."

Larry M.

"One of the most positive experiences we've had recently! Every time we need a instrument cluster repaired I call Keith. He is knowledgeable, courteous, and professional. The "turn-around" time is lightening quick, and the job is always done correctly. Just recently Keith went "above and beyond" and helped me through a diagnosis and repair at no charge-It is so refreshing to see a business today that believes in doing business with a "handshake" and recognizes customer service and goodwill are keys to success. I ALWAYS RECOMMEND YOU TO OTHER MECHANICAL SHOPS IN NEED OF INSTRUMENT CLUSTER SERVICE! Thank you Keith and R.T. Grim."

Steve - 2/13/2016


Hello There