• 717-761-4113

  • 3925 Trindle Road Camp Hill, PA. 17011

  • Hours: Mon. - Fri. 8:30 AM to 5:00 PM

Testimonials

"The radio is back in and works great – thanks. You’ll be hearing from us again when we need your services."

Richard

"Just wanted to send a note of appreciation for the fast service on repairing my Ford instrument cluster. It is refreshing to find a business with fine service such as yours. Thank you!"

Charlie - 9/8/2015

"We received the cluster on Monday. Installation was delayed a few days because of snow (in May) but we got it in yesterday and made a test run today. Eureka! We have speedo, cruise and no surging. Most likely not a monumental result in the big scheme of things but we're over the moon. I'm wearing out the screw holes taking the darn thing In and out but hopefully this is the last time. Thank you so much for all of your help and advice and that you don't give up easily. There was no invoice in the box so just let us know if we owe anything. And again, thanks for doing all of this. I have passed on the Grim name to multiple people."

Bob & LuAnn - 5/21/2015

"Just wanted to thank you again for fixing my cluster! I must admit I was very hesitant to go through this process, but after talking with one of your associates who had knowledge about fixing these clusters, I gave it a shot. I have a 2004 Ford Explorer Sport Trac with 305k miles on it. For the last year, I've been putting up with huge annoyances related to the cluster failing. No dashboard instruments, no fuel gauge, no power to stereo or windows, automatic lights flickering on/off draining my battery, etc. I've had the cluster out myself so many times trying to fix it, but they were all band-aid solutions, and I wasn't sure if it was the cluster itself, or the wiring harnesses behind it. The real problem was in the circuit board, which I understood after talking with your company. And in less than a week after sending it in, I had it back and everything is working PERFECTLY!!! My only regret is I didn't do it a year ago! Thanks so much for providing a great service at a very fair price! Worth every penny!!! Happy Holidays!"

Mike - 12/17/2015

"Hey Guys, I just wanted to thank you for your great work and quick turn around on my 2003 Trailblazer cluster. It all worked great after installation!! I will highly recommend your company to anyone who needs a similar repair. Again, thanks for a great job!!!!!!!!"

Tom S.

"Received cluster for my 2006 Mercury and it works and looks beautiful. Thank you all so much for the great work and quick turnaround."

Bill - 7/17/2015

"Just a note to let you know that the unit you repaired works perfectly. Thanks again for the help and the fantastically fast service."

Michael S.

"I have a motorhome on a 2002 F-53 chassis. The instrument cluster is # 1C3F10849HA. The voltage gauge just wiggled when the key was turned on. It would slowly build to around 8 with the the engine running for a while. I had the alternator checked-it was ok. I installed a digital voltage gauge which shows 14.1-14.2 with the engine running. After sending it in for repair, I received the instrument cluster this morning, installed it and everything works fine now. Thanks!"

Curtis - 8/21/2015

"Keith the gauges are installed and work perfectly. Thank you for the excellent customer service. I will recommend everyone to your company! Thank you."

Mike - 1/23/2015

"The new cluster works perfect.  I just got a chance to check it out this past weekend.  Thanks for your help in getting the issue resolved."

Doug - 5/12/2015

1 2 3 5

Hello There